1. Dismiss Notice
  2. GOG.com logo

    Thanks to YOUR votes, GOG.com now sells:
    - Sea Dogs - Sea Dogs: Caribbean Tales
    - Sea Dogs: City of Abandoned Ships

    Vote now to add Pirates of the Caribbean to the list!

    Dismiss Notice
  3. Under the Crossbones Podcast

    A Pirate Podcast with Interviews
    Music, Comedy and all things Pirate!

    - Episode Guide - About - Subscribe -
    - Twitter - Facebook - iTunes - Android -
    - Youtube - Fill the Coffers -

    Dismiss Notice
  4. New Horizons logo

    Quick links for PotC: New Horizons
    - Download latest version
    - Wiki - FAQ - Report bugs here
    - ModDB profile

  5. GOF logo

    Quick links for AoP2: Gentlemen of Fortune 2
    - Downloads and info
    - Historical Immersion Supermod
    - ModDB Profile

Dismiss Notice
New to the forum?
Please take a moment to read our Welcome Message and Forum Rules.

new bug

Discussion in 'POTC: New Horizons Mod' started by morgan terror, Apr 26, 2007.

  1. morgan terror

    morgan terror Magnificent bastard Storm Modder News Gatherer

    Joined:
    Oct 31, 2006
    Messages:
    24,963
    Gender:
    Male
    when trying to use directsail, i keep getting updates every ten to twenty seconds. it's highly annoying, and i don't really get the chance to do anything. the wind direction and strenght doesn't change though. it seems to happen on roughly the border between two sections.
     
  2. CouchcaptainCharles

    CouchcaptainCharles COO (Chief Oddity Officer) Staff Member

    Joined:
    Jan 1, 1970
    Messages:
    1,410
    Can you post your errorlogs, especially the compile.log, please?
     
  3. Pieter Boelen

    Pieter Boelen (Not So) Old Seadog Staff Member Administrator Storm Modder Hearts of Oak Donator

    Joined:
    Nov 11, 2004
    Messages:
    66,593
    Gender:
    Male
    Occupation:
    Maritime Research: Project Engineer (Analysis)
    Location:
    Wageningen, The Netherlands
    Is that with the default settings? I never noticed that. <img src="style_emoticons/<#EMO_DIR#>/wacko.gif" style="vertical-align:middle" emoid=":wacko:" border="0" alt="wacko.gif" />
     
  4. morgan terror

    morgan terror Magnificent bastard Storm Modder News Gatherer

    Joined:
    Oct 31, 2006
    Messages:
    24,963
    Gender:
    Male
    i don't have any logs, although i did thought i had activated them. and now i can't run the game anymore as said in another topic, so it'll have to wait. maybe it has something to do with the fact that i accidentally ran Preset.bat two times straight after each other in stead of one. (at the right point)
     
  5. morgan terror

    morgan terror Magnificent bastard Storm Modder News Gatherer

    Joined:
    Oct 31, 2006
    Messages:
    24,963
    Gender:
    Male
    i think i just need the newest CCCdirectsail file. could someone give it to me?
     
  6. CouchcaptainCharles

    CouchcaptainCharles COO (Chief Oddity Officer) Staff Member

    Joined:
    Jan 1, 1970
    Messages:
    1,410
    There is one in <a href="http://www.piratesahoy.com/forum/index.php?showtopic=10211" target="_blank">this thread.</a>
     
  7. morgan terror

    morgan terror Magnificent bastard Storm Modder News Gatherer

    Joined:
    Oct 31, 2006
    Messages:
    24,963
    Gender:
    Male
    thankee! i'll see if that works. from what i could see between those ten seconds, it looked promising. i even found a dismasted ship! the strange thing was, i did so on the worldmap where you can't see it. <img src="style_emoticons/<#EMO_DIR#>/mybad.gif" style="vertical-align:middle" emoid=":facepalm" border="0" alt="mybad.gif" /> i also got mis-directed all the time. when it said something was dead ahead, it also mentioned the direction where it was, which WASN'T dead ahead. <img src="style_emoticons/<#EMO_DIR#>/mybad.gif" style="vertical-align:middle" emoid=":facepalm" border="0" alt="mybad.gif" /> well, i'll see if this file solves all those problems.
     
  8. morgan terror

    morgan terror Magnificent bastard Storm Modder News Gatherer

    Joined:
    Oct 31, 2006
    Messages:
    24,963
    Gender:
    Male
    the problem's still there. i'll check if the logging is actually turned off. i found out that the bug doesn't occur at the edge, of an area, but in any place when not fighting. it usually takes about one and a half hour of peacefull sailing to start appearing. although it sometimes doesn't.

    i also keep seeing this when not near an island:

    is that normal? heh. just noticed i cought a lighting bolt on picture. <img src="style_emoticons/<#EMO_DIR#>/smile2.gif" style="vertical-align:middle" emoid=":))" border="0" alt="smile2.gif" />
     
  9. Pieter Boelen

    Pieter Boelen (Not So) Old Seadog Staff Member Administrator Storm Modder Hearts of Oak Donator

    Joined:
    Nov 11, 2004
    Messages:
    66,593
    Gender:
    Male
    Occupation:
    Maritime Research: Project Engineer (Analysis)
    Location:
    Wageningen, The Netherlands
    Ah! THAT one! I know what causes that. And I know how to revert it back to it's old state. I'll include the change in my most recent files when I send them to Pirate_KK.
     
  10. morgan terror

    morgan terror Magnificent bastard Storm Modder News Gatherer

    Joined:
    Oct 31, 2006
    Messages:
    24,963
    Gender:
    Male
    good. so that'll solve the mass sail-ho-ness?

    i think i've incidentally discovered a new feature of the game. it seems that if you take a screenshot in a storm, the game will automatically make another screenshot when the next lightning bolt strikes. it's the only case where two screenshots are made, and the original screenshot i made of that storm didn't have the lightning bolt.
     
  11. CouchcaptainCharles

    CouchcaptainCharles COO (Chief Oddity Officer) Staff Member

    Joined:
    Jan 1, 1970
    Messages:
    1,410
    <!--quoteo(post=192316:date=Apr 30 2007, 09:53 PM:name=Pieter Boelen)--><div class='quotetop'>QUOTE(Pieter Boelen @ Apr 30 2007, 09:53 PM) [snapback]192316[/snapback]</div><div class='quotemain'><!--quotec-->Ah! THAT one! I know what causes that. And I know how to revert it back to it's old state.<!--QuoteEnd--></div><!--QuoteEEnd-->
    Glad to hear that <img src="style_emoticons/<#EMO_DIR#>/yes.gif" style="vertical-align:middle" emoid=":yes" border="0" alt="yes.gif" /> How?

    That "No island within reach" message should appear if directsail runs in the "Open Sea" location, as reminder that it actually doesn't work there. But what triggers that twenty second loop ???

    BTW, Morgan, did you change #define TIMESCALAR_SEA in internalSettings.h ?
     
  12. morgan terror

    morgan terror Magnificent bastard Storm Modder News Gatherer

    Joined:
    Oct 31, 2006
    Messages:
    24,963
    Gender:
    Male
    well, i did, but only a little while ago. i already had the bug before i changed it. i haven't played with the changed setting yet, though. i've set it from 5 to 10.

    it isn't always twenty seconds. it varies from 1 to 20.

    come to think of it, i've always had certain problems with directsail. usually minor, incosintent ones, and not nearly as severe as this.
     

Share This Page