1. Dismiss Notice
  2. GOG.com logo

    Thanks to YOUR votes, GOG.com now sells:
    - Sea Dogs - Sea Dogs: Caribbean Tales
    - Sea Dogs: City of Abandoned Ships

    Vote now to add Pirates of the Caribbean to the list!

    Dismiss Notice
  3. Under the Crossbones Podcast

    A Pirate Podcast with Interviews
    Music, Comedy and all things Pirate!

    - Episode Guide - About - Subscribe -
    - Twitter - Facebook - iTunes - Android -
    - Youtube - Fill the Coffers -

    Dismiss Notice
  4. New Horizons logo

    Quick links for PotC: New Horizons
    - Download latest version
    - Wiki - FAQ - Report bugs here
    - ModDB profile

  5. GOF logo

    Quick links for AoP2: Gentlemen of Fortune 2
    - Downloads and info
    - Historical Immersion Supermod
    - ModDB Profile

Dismiss Notice
New to the forum?
Please take a moment to read our Welcome Message and Forum Rules.

Need Help Age of pirates carribean sales! problem

Discussion in 'Age of Pirates Gameplay & Tips' started by AdamH1990, May 3, 2012.

  1. AdamH1990

    AdamH1990 Powder Monkey

    Joined:
    Feb 5, 2010
    Messages:
    43
    Hello all!
    sorry not been on in a while, not had a computer/laptop to play POTC but today i bought this game!, it looks amazing! and you can capture ports for your self? amazing!, anyway! , I have installed the game etc. I go to start the game and starforce protection is blocked so the game wont run? :(, Ive searched this site for more info, I tried searching google for starforce removal? I have tried to remove it 4 5 times using 2 different starforce removal programmes , Well i downloaded it twice so i think its different!. It says there are no drivers to be removed? but starforce is still on the laptop?.
    If someone could help me remove this programme to play this game! would be most appercated!.Also is there any build mods or patches I should get for this game??
    Cheers
    Adam!
     
  2. AdamH1990

    AdamH1990 Powder Monkey

    Joined:
    Feb 5, 2010
    Messages:
    43
    To Add!, I removed starforce and the game wouldnt start, I reinstalled the game and starforce, it loads the starfoce but says install complete click yes to restart and continue , This is as far as i get, the laptop restarts everytime . Have i bought a crappy game i cant run? :|, The laptop as inte celeron 1.73 processor, 500GB harddrive, 150GB ram windows 7 32bit service park 1, grahpics card is intel graphics media accelerator driver. not heard of this one before. I hope someone can help!,
    Adam
     
  3. Grey Roger

    Grey Roger Sea Dog Staff Member Storm Modder

    Joined:
    Feb 12, 2007
    Messages:
    6,405
    You can get a NoCD (actually No DVD) patch here:
    http://gamecopyworld.com/games/pc_age_of_pirates.shtml

    Make sure you get the right patch - there's one for the basic version 1.41 and another if you've used the official version 1.50 patch.

    Or you can get the Supermod:
    http://www.moddb.com/mods/age-of-pirates-supermod/downloads/aop-supermod-repack-final

    As well as a No DVD patch, this opens up a variety of other features, not least of which is the city gates - you can now leave the city and walk around the island.

    Manual instructions to remove Starforce can be found here:
    http://www.glop.org/starforce/remove.php
     
  4. Ben Coats

    Ben Coats Freebooter

    Joined:
    Mar 28, 2012
    Messages:
    390
    Gender:
    Male
    Occupation:
    Firefighter
    Location:
    CSA
    i have AoPCT 1.41 on my grandma's pc and it works fine, i put it on mine and it said "you must run this in admin mode" so i tried that it said "reboot for to take affect", i did, and computer failed to start, so the startup repair came on and deleted AoPCT. and i cant even get the starforce removal to work WTH!!! :thumbsdown2
     

Share This Page