1. Dismiss Notice
  2. GOG.com logo

    Thanks to YOUR votes, GOG.com now sells:
    - Sea Dogs - Sea Dogs: Caribbean Tales
    - Sea Dogs: City of Abandoned Ships

    Vote now to add Pirates of the Caribbean to the list!

    Dismiss Notice
  3. Under the Crossbones Podcast

    A Pirate Podcast with Interviews
    Music, Comedy and all things Pirate!

    - Episode Guide - About - Subscribe -
    - Twitter - Facebook - iTunes - Android -
    - Youtube - Fill the Coffers -

    Dismiss Notice
  4. New Horizons logo

    Quick links for PotC: New Horizons
    - Download latest version
    - Wiki - FAQ - Report bugs here
    - ModDB profile

  5. GOF logo

    Quick links for AoP2: Gentlemen of Fortune 2
    - Downloads and info
    - Historical Immersion Supermod
    - ModDB Profile

Dismiss Notice
New to the forum?
Please take a moment to read our Welcome Message and Forum Rules.

Bug Game freezes when in invetory screen or when selling cargo

Discussion in 'Technical Help' started by Amon, Jan 9, 2016.

  1. Amon

    Amon Landlubber

    Joined:
    Oct 23, 2012
    Messages:
    8
    Gender:
    Male
    The game freezes as soon as you try to list through items in your inventory. When i installed the latest POTC Build the problem was a bit solved, but not completely, now when i go through items in my inventory, or when buying or selling cargo at the trader, it takes the game 10-15 seconds to move from one item to the other. The game lags terribly when in trader or inventory screen, also, when i enter the tavern, a ship yard, the trader, or any closed space, the character turns left and right very very slowly... what could be the problem?

    I use Win 10 with AMD Radeon R9 380
     
  2. Pieter Boelen

    Pieter Boelen (Not So) Old Seadog Staff Member Administrator Storm Modder Hearts of Oak Donator

    Joined:
    Nov 11, 2004
    Messages:
    66,575
    Gender:
    Male
    Occupation:
    Maritime Research: Project Engineer (Analysis)
    Location:
    Wageningen, The Netherlands
    I've seen some tremendous slow motion on Windows 10 before, but the very latest modpack version did solve it in that case.

    Have you tried to install ENB? Maybe that helps?

    Also, to be certain, what is the modpack version and date that is shown in your main game menu?
     
  3. Hylie Pistof

    Hylie Pistof Curmudgeon Staff Member QA Tester Storm Modder

    Joined:
    Jan 15, 2010
    Messages:
    13,754
    Gender:
    Male
    That is winX causing your problems. I have similar issues that I mostly worked around by fine tuning the video card settings. Too high of a frame rate causes the game to run in slo mo.

    Basically what happened is winX forces POTC to run in windowed mode which trashes the game.

    What are your puter specs? I am running an AMD FX 8370 and a 290X.
     
  4. Amon

    Amon Landlubber

    Joined:
    Oct 23, 2012
    Messages:
    8
    Gender:
    Male
    Yes, i have a more high-end pc...
    Here is my DXdiag file...
    What video-card settings would you recommend?
     

    Attached Files:

  5. Amon

    Amon Landlubber

    Joined:
    Oct 23, 2012
    Messages:
    8
    Gender:
    Male
    I am using modpack: Build 14 Beta 3.4
     
  6. Amon

    Amon Landlubber

    Joined:
    Oct 23, 2012
    Messages:
    8
    Gender:
    Male
    Ah, it is ok now. It was my mistake, i thought i had build 3.4 but it was 3.3
    Now that i installed the latest WIP build (Jan/2016) it works flawlessly :)
     
    Pieter Boelen likes this.
  7. Amon

    Amon Landlubber

    Joined:
    Oct 23, 2012
    Messages:
    8
    Gender:
    Male
    Yeh, it worked for some time... but again, slow mo problems, it is playable, but annoying...
     
  8. Hylie Pistof

    Hylie Pistof Curmudgeon Staff Member QA Tester Storm Modder

    Joined:
    Jan 15, 2010
    Messages:
    13,754
    Gender:
    Male
    I didn't reply before because you said it was working ok, but it seems you still have the slo mo problem. So...........

    In CCC create a preset for POTC and set everything to the max settings except morphological filtering. Play the game like that and then adjust the settings to get the best compromise between frame rates and game speed.

    Basically what happens in my system is that frame rates are no longer capped at 60fps and the farther past that they go the slower the graphics runs. My solution is to put a max load on the GPU to slow down the frame rate.
     

Share This Page