1. Dismiss Notice
  2. GOG.com logo

    Thanks to YOUR votes, GOG.com now sells:
    - Sea Dogs - Sea Dogs: Caribbean Tales
    - Sea Dogs: City of Abandoned Ships

    Vote now to add Pirates of the Caribbean to the list!

    Dismiss Notice
  3. Under the Crossbones Podcast

    A Pirate Podcast with Interviews
    Music, Comedy and all things Pirate!

    - Episode Guide - About - Subscribe -
    - Twitter - Facebook - iTunes - Android -
    - Youtube - Fill the Coffers -

    Dismiss Notice
  4. New Horizons logo

    Quick links for PotC: New Horizons
    - Download latest version
    - Wiki - FAQ - Report bugs here
    - ModDB profile

  5. GOF logo

    Quick links for AoP2: Gentlemen of Fortune 2
    - Downloads and info
    - Historical Immersion Supermod
    - ModDB Profile

Dismiss Notice
New to the forum?
Please take a moment to read our Welcome Message and Forum Rules.

Bug I am back! And so are some bugs.

Discussion in 'Build Support & Troubleshooting' started by Bathtub-pirate, Oct 1, 2017.

  1. Bathtub-pirate

    Bathtub-pirate Sailor

    Joined:
    Feb 15, 2013
    Messages:
    167
    Gender:
    Male
    Hi mates!

    I got around to fire up my ol' lappy and play some much desired POTC Build. I ran the most current installer and unpacked the according archives and then the latest patch on top of it.

    And something is awry. The flags sometimes randomly change and are not consistent with the factions. A ship may be displayed as one faction in my spyglass (it's accurate faction) but be under a different flag. Or my pirate flag magically changes. It usually resolves itself when I enter other waters or a "sail ho" prompts the surroundings to reload. But I can't point the finger on what is triggering this stuff to happen. It happened in a game, for example, where I have yet to even take a ship.

    Also, when I lured a few Spaniards near an English fort to pick up the left-overs, one spanish ship got hammered and struck it's colors ..... only to be bombarded by the other Spaniards, as soon as it did so. Is that supposed to happen?

    Do I have a bad save game already?

    Also, what is the current status on saving on sea? Is that still something that is to be avoided like the plague?

    Edit: Uploaded compile and error log. Accidentally uploaded the compile twice. So don't bother. It's the same.
     

    Attached Files:

  2. Hylie Pistof

    Hylie Pistof Curmudgeon Staff Member QA Tester Storm Modder

    Joined:
    Jan 15, 2010
    Messages:
    13,762
    Gender:
    Male
    :ahoy

    I know nothing about those flags as I don't have that problem and can not recall hearing about it before.

    About the surrendered ship being fired upon by the other ship, yes that is normal.

    I save at sea all the time, especially right after a battle. The only issue is if you then quit, when you restart there your escort ships will not move until you give them orders to do so.
     
  3. Bathtub-pirate

    Bathtub-pirate Sailor

    Joined:
    Feb 15, 2013
    Messages:
    167
    Gender:
    Male
    Hi there!

    It's not as bad as it sounds. It doesn't happen often and it doesn't seem to get in the way of the functionality of the game. It's basically just a matter of inaccurate display. Irritating only for mere mortals like me. What is also weird is that after taking a ship, it is displayed as fully repaired even though it clearly took damage. In one instance I took a dismasted Merchantman as a price. It's "health bars" were all the way up. But it still was dismasted and as slow as one would expect it to be. Later, when I repaired the ship in a shipyard, it was still displayed as being a 100%, even though there were repairs to be made worth 8.000 or so coins. And when I ordered these repairs, they happened on the spot. No time went by (it should have taken several days). Very weird.
     
  4. Pieter Boelen

    Pieter Boelen (Not So) Old Seadog Staff Member Administrator Storm Modder Hearts of Oak Donator

    Joined:
    Nov 11, 2004
    Messages:
    66,593
    Gender:
    Male
    Occupation:
    Maritime Research: Project Engineer (Analysis)
    Location:
    Wageningen, The Netherlands
    Very occasionally, the Flags code gets confused, usually of a mast fell somewhere.
    You can then get wrong flags in spots, in which case the spyglass/interface flags are correct.
    But this should be quite a rare occurrence.

    But it shouldn't be! :shock
     
  5. Hylie Pistof

    Hylie Pistof Curmudgeon Staff Member QA Tester Storm Modder

    Joined:
    Jan 15, 2010
    Messages:
    13,762
    Gender:
    Male
    Why not? They are mad that the other ship surrendered I suppose. Anyway, I can't remember a time when that did not happen.
     
  6. Pieter Boelen

    Pieter Boelen (Not So) Old Seadog Staff Member Administrator Storm Modder Hearts of Oak Donator

    Joined:
    Nov 11, 2004
    Messages:
    66,593
    Gender:
    Male
    Occupation:
    Maritime Research: Project Engineer (Analysis)
    Location:
    Wageningen, The Netherlands
    Because the neutral nation is supposed to be neutral to everyone.
    That's the way it is meant to be, in any case.
    Apparently that doesn't work. :facepalm
     
  7. Hylie Pistof

    Hylie Pistof Curmudgeon Staff Member QA Tester Storm Modder

    Joined:
    Jan 15, 2010
    Messages:
    13,762
    Gender:
    Male
  8. Bathtub-pirate

    Bathtub-pirate Sailor

    Joined:
    Feb 15, 2013
    Messages:
    167
    Gender:
    Male
    Nevermind, my flag related problem (and other occurences of minor weirdness) were probably down to me not installing the game properly.
     
    Pieter Boelen likes this.

Share This Page